Com board busy - cannot upload to redboard artemis


I am using Arduino IDE 2.1.1 on Windows Home 11. I simply trying to communicate and upload the example “Blink” to my new Sparkfun RedBoard Artemis. I have added the Sparkfun github definitions to the Board manager and the code compiles and begins to upload but always returns this error:

"Artemis SVL Bootloader

COM1 is currently open. Please close any other terminal programs that may be using COM1 and try again."

I have rebooted the computer and board, and I have switched USB ports. No luck.

Thanks in advance for any solutions!

Just to add this, I also tried on two different computers, both running windows 11 home version. Same error.


Please check you have the correct COM port selected in the IDE Tools \ Port menu. COM1 is probably your computer’s default COM port. It is very unlikely that the Artemis is actually connecting as COM1.

You can use the Windows Device Manager to check which COM port the Artemis is using.

I hope this helps,


Mine worked fine; load the IDE and look at the available COM ports, then plug it in…did a new port appear?