Files data from OPEN LOG ARTEMIS through Zmodem (Tera term)


I have no success to transfer files data from OpenLog through ZModem. It is OK to ask the transfer with Sz xxx file with Arduino Terminal (it works perfectly with Dir command). Immediately, I ask for a Z modem transfer on Com6. But the Receive screen shows nothing, no elapsed time, even when Arduino terminal says that the transfer is complete.

Any idea ?


Hi Christian,

Please follow this link and scroll down to the bottom of the page. Does this help? … figuration

You need to wait 20 seconds for the transfer to start. But after that, you should see the green progress bar.

I hope this helps,


Thank you Paul,

Of course, I have used the link and I have waited 20 seconds but the green bar never progressed …

I have also modified the 14 option of terminal set up …

I have modified at 115600 baud rate the Zmodem set up …


Hi Christian,

Very curious…! This is still working OK for me with version 2.5 firmware:

Which version of the firmware is your OLA running? And which version of the OLA do you have? Is it a Red SparkFun board, and does it have the ICM-20948 IMU chip installed?

Thank you,


Oh. OK. Are you trying to transfer the file via USB - or are you trying to use the TX and RX pins?

In the above image, I am connected via USB. I have not tried using the TX and RX pins… I think that feature still works, but I have not tested it for a long time.



Just in case it was not clear:

If you are connected via USB, the file transfer takes place over USB.

If you are connected via the TX and RX pins, the file transfer takes place over TX and RX.

You can not open the file transfer menu on USB and then transfer the file via TX and RX.

I hope this helps!


Version is v2.3 (special to use NEO at 25 Hz).

I started to transfer through USB but as it was not working, I tried to change some parameters that I supposed to concern the transfer (data rate, Option 14 of the configure terminal output …)

… A big issue is that I cant reverse this option 14 (see set up)

In addition, I see lack of options in the main menu (see attached picture)

Obviously I am in a bad situation


Capture d’écran 2023-04-20 182943.png

Hi Christian,

Option 3 will be missing if the IMU is not installed or not detected.

Option 4 is missing because you have enabled the console on the TX and RX pins.

I still can not explain why the Zmodem transfer is not working for you. Just as an experiment, please try: opening the file transfer menu; disconnect the GNSS; then transfer the file. I wonder if having the GNSS connected and outputting messages very quickly is causing problems?

I hope this helps,


Does your terminal emulator software even support Zmodem?

Thank you both of you,

For Yellow Dog, I suppose my terminal Tera Term supports Zmodem as it proposes it in the menu.

For Paul, I have stopped the GNSS logging but the transfer no more works.

I have attached the image of what appears in the Arduino screen : at least, it shows that there is communication as I have a return concerning the directory of the SD card.

Maybe my SZ command is not correct ?

Concerning the option 3 not active, I don’t understand what happened to the IMU ?

Concerning the option 4 not active, I have no effect when I use the option 14 in the menu of the terminal to disable console on TX and RX pins ?


Hello Christian,

It does look like the zmodem transfer is working correctly. Perhaps file 79 is corrupt in some way? Perhaps try transferring a smaller file first. Does that work?

You can restore option 4 by resetting the OLA settings - select option “r” at the main menu.

I can’t explain why option 3 is missing if it was there previously. We do have a version of the OLA which has no IMU. Option 3 is missing on those boards:

I hope this helps,


Hello Paul,

After resetting the OLA Settings, option 3 and 4 appears.

But when I tried to transfer another file smaller (8000 bites) I have had no more success …

I find again strange kind of answer before “zmodem transfer complete”


Hello Christian,

There is no handshaking in the zmodem file transfer. The sz command causes the OLA output the file to USB (or the TX pin) in zmodem format - without checking if anything is “listening” for the data. The transfer will always complete…

Please try:

Connect the OLA to your computer via USB

Open Tera Term - using the USB COM port

You should see the sensor data being logged to SD card

Press a key to open the menu

Select the file transfer menu

Use ls to list the files

Use sz filename to start the zmodem file transfer

You then have 20 seconds to put Tera Term into zmodem receive mode

If all is well, you should see the green progress bar increase. The window will close when the transfer is complete.

Please do not connect anything to the TX and RX pins.

Please do not configure the TX and RX pins for the terminal.

Please do everything through Tera Term, connected via USB only.

I hope this helps,


Hello Paul,

Many thanks as transfer works … if I use a correct COMx with Tera term.

The last trouble is that the menu is not clear as shown in the attached file.

I precise that I have tried various configuration for the serial port

Thank you again

I’ve seen this happen before, disconnect then restart your terminal emulator and it should be OK. Some data coming in over serial is changing terminal emulation modes and it starts treating text as binary.

Yes, indeed. It’s a ‘feature’ of Tera Term…

Hello both of you,

All is clear now

Many thanks