MyoWare sensor not showing muscle activation

I am using my myoware sensor with a link shield, trs cable, snd arduino shield. I tried hooking the sensor up to the flexor digitorum superficialis and wasnt able to see any peaks in the serial monitor when flexing my muscle. It stayed around 540. Then I hooked it up to the bicep in the middle of the muscle(ive read the elctrode placement guide) and the refernce cable for the gnd electrode was around a bony part of the arm. I am still not seeing peaks when i flex, sometimes the sensor is getting so saturated it stays constantly at 940. What is going on?

There is a tiny variable POT on the back of the PCB for adjusting gain. Did you try to vary that?

yes i did try to adjust the gain and it was still showing the same results. i have been looking into maybe gerting a usb isolator for it?

Make sure the TRS cable is completely plugged in.

Sometimes they look and feel fully plugged in when pressing just a bit harder will make the go a few mm further and be fully plugged in.

Been bitten by this a few times before!