OpenLog Artemis - Won't Run/Reset with uSD Inserted

Hello - I’m seeing some odd behavior trying to get my OpenLog Artemis up and running.

Hardware:

OpenLog Artemis (no IMU) running 2.2 firmware

Qwiic NAU-7802 module

32GB uSD card (from Sparkfun)

Problem:

When powering up (via USB-C to my computer) the OpenLog Artemis I get no lights. Hitting reset results in a single flash of both the STAT and PWR led. My computer detects the Serial Adapter, but I cannot connect to it.

I have managed to get the system working again by removing the uSD card, powering on (via USB) and then hitting reset. The device come online, LEDs blink as expected, and I can connect via Serial. Once I disconnect and/or power down the system, inserting the uSD and power back on gets me back to no lights/no activity.

One thing that works is reseting the OpenLog Artemis (via the serial commands). When this is done the PWR led stays on even after removing the USB cable. I can then insert the uSD card (which causes the PWR light to go off), power on the system (via USB), and then it works as normal. However if I disconnect and reconnect the power, it stop working again (no lights).

Other things I’ve tried:

-Reformatting the uSD card using the recommended formatter (full format)

-Deleting everything from the uSD card

-Having the NAU7802 module connected and disconnected (no difference)

-Powering via battery (Sparkfun 1200mAH Li-Ion module)

I also have a new uSD card on the way in case this is a buggy uSD.

I think the only option left is to try another microSD card. If you have another microSD card, you can give it a try. Otherwise, I think you should reach out to Sparkfun’s technical support ASAP.

Hi @TheGreenCastle,

This is a puzzle. I think you are the first customer with this issue - I don’t remember anyone else having the same issue.

It does sound like a microSD issue. It sounds as if the microSD is causing the power to “brown out” (drop to a level which causes the power-fail interrupt to put the Artemis into deep sleep). Please do try another microSD card. If you see the same issue again, then we will arrange a return or replacement for you.

The only other thing I can think of is that maybe the combined power draw of the Artemis + battery charge circuit (which draws 450mA) + microSD card (which can have a high in-rush current depending on the card) is causing your USB port to brown out. Please try your test again, without connecting the battery. That way the current draw will be much lower. Do you see a difference?

Very best wishes,

Paul

New SD card arrived today and the unit is now working as expected. @PaulZC I think you are correct re brownout, thanks for the assistance.

Couple last notes for posterity:

  • - RTC was reset often/always(basically every time I got it working again)
  • - I was suspicious of the USB power (handshake or controller issues), so I tried running on battery only, but saw the same results.
  • - I also tried running it from a cell phone charger (again suspicious of the USB connection), also same results.
  • Finally the card that worked was a Sandisk Ultra 16GB UHS-I. The bad card was a 32GB Kingston Canvas Select Plus (also UHS-I).

    Thanks for the update. I’m glad the new card is working for you.

    If you try the Kingston card in your PC, it may work OK. It just needs more current on start-up (the in-rush) than the OLA can provide. The in-rush varies considerably from card to card.

    If you want to return the Kingston card, please submit an RMA request and add a link to this forum issue in the “Why do you want an RMA?” section. Apologies for the inconvenience!

    https://www.sparkfun.com/returns

    Best wishes,

    Paul

    I ran into the same problem with the SanDisk Ultra UHS-I 32GB card. It worked the first time I powered it up, but never again. I tried two different copies of the same card with the same results. When i tried to connect with Tera Term (via USB), it would cycle endlessly, connecting and disconnecting over and over again. I tried an older 4GB micro SD card and it works.

    Hi,

    Thanks for the update. Glad that’s working for you. Apologies for the hassle…

    Best wishes,

    Paul