Sparkfun Openlog Artemis will not enter menu

Hello together,

I have recently bought a Sparkfun Openlog Artemis without the IMU and I wanted to play around with it but right from the start I have a problem. When I plug in the board via USB I can see it working in the Arduino IDE or in Realterm but when I try to enter the menu by pressing “send” nothing happens. I just followed what is written here: … figuration . I also tried different cables and different computers (Windows ans Linux) without success.

Maybe I am missing something fundemantel. I would really appreciate it if someone could help me.

Thank you in advance!


Please make sure you have “line endings” turned on. For the Arduino IDE Serial Monitor, please set the drop-down menu box to “Newline”.

I hope this helps,



thanks for your reply. I double checked that but still no success.


Thanks for checking that.

I am not sure what else to suggest. A hardware fault seems unlikely, because I’m sure we fully test the USB interface while we are configuring the board with the OLA firmware. But maybe it is a bad joint on the CH340 (the small chip on the bottom of the board, directly under the USB connector), or under the Artemis itself.

If no one else replies in the next 24 hours, please start a return at or through your local supplier.

Apologies for the inconvenience,


Thanks again, I will do so. Things like this can happen so no worries.

Today I received a new Openlog Artemis (with IMU) and I can enter the menu without any problems. Therefore I would say the old one is definitely defective.

Thanks for helping!

Many thanks for the update and apologies again for the inconvenience.

Best wishes,