AVR pocket programmer not working at all


I just bought the pocket programmer form spark fun. I installed the drivers and everything, but the pocket programmer doesn’t show up in windows at all. Not in the device manager. The power light is the only light on, and no other light. Is my pokiest programmer defective and can I get a refund?

The power light is the only one that should be on when you aren’t uploading anything. Have tried just plugging in the programmer without anything else connected to it? Also make sure that you have the right drivers, i.e., the correct architecture (x86 or x64).

I disconnected everything and tried to install the drivers but it still didn’t work nor did it show up in device manager. I cannot install it because it doesn’t show up in device manager. I am running windows 7 Pro. 32bit

In your first post you said you installed the drivers, then in the reply you stated you can’t install them. So which is it?

Yes, you can install the drivers without having to plug in the programmer. There is a link to the driver on the product page.

I have installed the drivers, I don’t know what I was thinking when I said I didn’t. I made sure the USB cable was data and power. The drivers installed for x86 (my architecture). They install successfully, but AVRDUDE says could not find USBtiny device.