My computer cant find ""

I am seeing a similar issue. When I tried to add SparkFun Apollo3 Boards using the Arduino boards manager, I get the following error:

Error downloading

java.lang.RuntimeException: java.lang.Exception: Error downloading

at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(


I have added all of the following URL’s to the boards manager in preferences:

Interestingly, I was able to add the Apollo v1.2.3, however I still get the above error when I try to update it to the current version. I also tried uninstalling and re-installing the Arduino IDE, which did not solve the problem.

Which version of the IDE are you using? The board definitions only work with Arduino 1.8.12 and below.

If you need 1.8.12, you can grab it at the link below.

  • - [1.8.12 for Windows
  • - [[1.8.12 for Mac](
  • [/list]](](

    Is this still the case 2 years later? I’m using Arduino IDE 1.8.19 on Mac OS 10.13.6 (High Sierra) and trying to install the Apollo3 boards definition results in:

    Error downloading … ac.tar.bz2

    However, if I point my web browser at that URL it does indeed download a 106MB bzip file.

    Anyone know what’s going on there?

    Hi Matt,

    We changed the name of the branch where the Apollo3 package lives a long time ago. From master to main. It was the right thing to do. Please make sure the Additional Board Manager URL has main in it - not master. Please also make sure you delete any extra copies of that line, it needs to be there only once.

    TLDR: there is a redirect from the old master branch to the main branch. Your web browser is clever enough to follow it, but the IDE isn’t…

    This should get you going,


    Hi, Paul. The URL I’ve added for additional boards is: … index.json

    That looks correct to me and this URL does serve up a JSON file.

    I just ran the Arduino IDE from the command line on the hunch that there might be something useful being written to stdout. Trying to install the Apollo 3 boards resulted in this:

    Error downloading … ac.tar.bz2

    Caused by: Received invalid http status code from server: 403





    … 5 more

    And to confirm from another Linux machine I tried downloading with wget and see this:

    $ wget … ac.tar.bz2

    –2023-05-16 07:21:50-- … ac.tar.bz2

    Resolving (…,, 2600:1f18:41d4:e9fb:8dfe:a279:409b:e170, …

    Connecting to (||:443… connected.

    HTTP request sent, awaiting response… 403 Forbidden

    2023-05-16 07:21:51 ERROR 403: Forbidden.

    To recap:

    • Able to download the file:

    • Safari and Brave on MacOS

    • Firefox and Chromium on Linux

    • Unable to download because the webserver gives a 403 Forbidden:

    • Arduino IDE on MacOS

    • wget on Linux

    Could there be some misconfiguration of that webserver that isn’t always serving the file when it should?



    Hi Matt,

    I just tried with IDE 2.1.0 on a Mac Mini. Apollo3 2.2.1 downloaded and installed just fine for me - all from inside the IDE:

    Sorry - I don’t know what else to suggest.

    Best wishes,


    Paul, I’m getting the same error that Matt is getting when trying to install the Sparkfun Apollo3 Boards, following the instructions exactly under Artemis Software Setup. I’m running Arduino IDE 1.8.19 on both my iMac (macOS 10.15.7) and my Raspberry Pi 4B Rev 1.2. Regardless of which version I select at the Boards Manager I get the same error when I click “Install.” On the mac the error is: “Error downloading … ac.tar.bz2”. On the Pi I get: “Tool arm-none-eabi-gcc is not available for your operating system”.

    The instructions do not indicate having to upgrade the Arduino IDE to 2.1.0, which is problematic with the Pi anyway. Any other suggestions?


    Hi Matt / Dan,

    I just tried with 1.8.19 and it worked OK for me. I even tried uninstalling Apollo3, close IDE, reopen IDE, and reinstall - and it worked OK:

    I’ll ask our Sys Admin if he’s aware of any issues. But, right now, I can’t replicate what you guys are seeing.

    Best wishes,


    Sparkfun Sysadmin here - Give it a try now

    Just tried it on my Surface Pro running Windows 10 Pro, after updating the Arduino IDE to 1.8.19. Got a similar error tring to install the Sparkfun Apollo3 boards:

    “Error downloading …

    Same error regardless of version number, 1.2.1 (as in instructions) or 2.2.1 (latest).

    This is very strange. Why same error on 3 different computers on same network? I looked at the preferences.txt file shown under the “Additional Boards Manager URLs:” line. It shows “boardsmanager.additional.urls=” without the URL shown in the box above. ( … index.json ) Is this normal? Should that URL be written into the preferences file?


    Dr Mantis, whatever you did worked for both my Mac and PC. Got Apollo3 installed on those two computers now. But still not able to get it installed on the Raspberry Pi. Error remains:

    “Tool arm-none-eabi-gcc is not available for your operating system.”


    Sparkfun Sysadmin here - Give it a try now

    It just installed on my 1.8.19 Arduino IDE on MacOS.

    Thank you!

    Well, drat. I tried versions all the way down through 2.0.5 and they include a dynamic library that was built for MacOS 10.15 and newer. I’m on 10.13.6 and can’t upgrade this iMac any further.

    Version 1.2.3 doesn’t have support for my new board, the SparkFun LoRa Thing Plus.

    Does anyone know if its possible to build the 2.2.1 Apollo3 boards library on MacOS 10.13? I see that the Arduino IDE 2.1.0 is only supported on MacOS 10.14 and newer.

    May be getting time to install Linux on this iMac, but would love to hear any other ideas.