No LEDs activating on Pulse Oximeter and Heart Rate Sensor - MAX30101 MAX32664 (SEN-15219)


I soldered headers to the sensor board and seem to be getting successful responses from the MAX32664 using the library from GitHub. I tried using both modes to check the extended status/LED counts. However, all the values are 0 and neither LED from the MAX30101 seem to be turning on. MFIO and RESET are connected to D6 and D5, respectively. Is there something I’m missing with the setup?


Share a few photos of the soldering/setup

Sure, please see the attached. I tried using both an Analog Discovery 3 (pattern generator on RST and MFIO, I2C protocol on the I2C pins) and the Particle Boron 404X. Double-checked it wasn’t 3.3V that was the issue – I2C lines behave appropriately by staying pulled up when the MAX32664 isn’t powered, and are pulled down when issuing the 0x02+0x00 Device Operating Mode status register check to 0x55 (0xAA/0xAB).

That solder connection on the GND pin isn’t looking too good; try reheating it; adding some flux or a touch of fresh solder may help.


Thanks Mike! I swapped the wiring around too (been a while since I breadboarded, haha…) and the sensor works now too. Mods, please mark this as solved!